Idle issue surging/dying at idle and or idle while steering

Bigtoeout93

New Member
Jul 4, 2020
1
0
1
29
So I have a 93 silverado 1500 standard trans 4.3 v6. Truck sat for about 6 months because it had a freeze plug leaking between motor and trans, (had 2 other projects didnt want a third at the time) anyways finally when I got to dropping the trans, to replace the freeze plugs (did both behind motor while I was at it) I also replaced clutch, rear seal, fly wheel, while I was in there. Did a fuel filter on it, dizzy cap, rotor, spark plugs and wires, tstat. Then when I started her up had no clutch (master took a shit) so replaced that too. Anyways ran fine first day. Now for the past month been chasing down a surging issue. So when idling its sitting around 800, then randomly will just drop and die or occassionally die for split second but save itself, if I keep the gas pedal depressed a smidge to hold the rpms steady it's fine. Also notice IT HATES reverse it wants to die anytime I'm in reverse. I replaced IAC didnt fix problem, then One day going to a drive in waiting in a long line instead of letting truck continually dye I just held the rpms up, which forced a code, it through a bad o2 sensor (made sense must be why it's running rich) replaced o2. Didnt fix problem, replaced map, didnt fix problem replaced tps, didnt fix problem. Cleaned throttle body, all vacuum hoses are fine, at this point not to sure where to look, injectors spraying fine. I know it's not power steering pump cus it will do it at idle regardless of steering (just hates being under load at idle more constistantly than just idling itself). Thanks in advance
 

TheBrettster

Administrator
Staff member
Dec 9, 2010
2,636
197
63
So I have a 93 silverado 1500 standard trans 4.3 v6. Truck sat for about 6 months because it had a freeze plug leaking between motor and trans, (had 2 other projects didnt want a third at the time) anyways finally when I got to dropping the trans, to replace the freeze plugs (did both behind motor while I was at it) I also replaced clutch, rear seal, fly wheel, while I was in there. Did a fuel filter on it, dizzy cap, rotor, spark plugs and wires, tstat. Then when I started her up had no clutch (master took a shit) so replaced that too. Anyways ran fine first day. Now for the past month been chasing down a surging issue. So when idling its sitting around 800, then randomly will just drop and die or occassionally die for split second but save itself, if I keep the gas pedal depressed a smidge to hold the rpms steady it's fine. Also notice IT HATES reverse it wants to die anytime I'm in reverse. I replaced IAC didnt fix problem, then One day going to a drive in waiting in a long line instead of letting truck continually dye I just held the rpms up, which forced a code, it through a bad o2 sensor (made sense must be why it's running rich) replaced o2. Didnt fix problem, replaced map, didnt fix problem replaced tps, didnt fix problem. Cleaned throttle body, all vacuum hoses are fine, at this point not to sure where to look, injectors spraying fine. I know it's not power steering pump cus it will do it at idle regardless of steering (just hates being under load at idle more constistantly than just idling itself). Thanks in advance

EGR, PCV ?
 

Tylers88

3 GM's and a Jeep
Apr 16, 2012
6,848
442
83
30
Clarion, IA
Check for vacuum leaks, easiest way is with spraying carb cleaner on And listen for engine speed to change, another thing with TBI trucks is to make sure the IAC motor is working and passage is clean