I think...my AC stopped working after my e fan swap.

Cleanoh4

Well-Known Member
Aug 27, 2013
4,342
182
63
37
NJ
I have no amp. Today i tried to jump start the compressor with wire and it won't even engage. Checked comp fuses and relay and all look good. Assuming now as mentioned before could be coincidence the compressor went out during the swap.

If it checks out and it is a bum compressor, might as well replace the accumulator, and liquid hose at minimum
 

Fourstar07

Active Member
Jan 23, 2011
1,399
1
38
Checked the voltage from where you would jump start the AC compressor and it comes
Out to be 4.83 the same as my step dads truck which does work.
 

ScottyBoy

The LED Man
Apr 6, 2012
1,320
21
38
Also, before you resort to replacing the compressor, connect a set of gauges to it. If the refrigerant is low that will cause the compressor to not come on. Its very possible that you have a bad AC hose that you touched or leaned against while installing the fans and that caused the refrigerant to leak out. I had a vehicle before like that, it was OK as long as you didn't touch the hose. If you touched the hose it would hiss a little bit at the fitting. I ended up having to replace the line.
I doubt that that is your issue, but you never know. Wouldn't hurt to check the pressures before throwing a new compressor on there.
 

Fourstar07

Active Member
Jan 23, 2011
1,399
1
38
Thanks dudes no update right now, been swamped with other things. But I will definitely keep you updated if I get it working!