SamCarroll

Faux Runner
Staff member
Jan 25, 2011
7,740
1,979
113
Northern California
My dads truck, 07 Classic Sierra sometimes doesnt recognize the front doors are open. He has amp steps and they will randomly not come down when he opens the door. I noticed his dome light comes on, but the key buzzer doesnt chime when the doors open sometimes. We tested it to see what it might be. We have replaced the amp step brain with no change. We just replaced the aftermarket radio harness thinking that might be it, nope. The truck wasnt touched whatsoever until he bought it so its not been tampered with.

Does anyone have any other ideas? Tricks to try? Its only the front two doors, if we open the rear it recognizes right away and drops the steps.
 

Graystone

Well-Known Member
Apr 25, 2014
1,315
213
63
39
It's the latch. Make sure it is lubed well.

You should be able to do it in the truck but it would not hurt to take it out. You will do a better job that way
 
Last edited by a moderator:

TechieTruckGuy

3.5 EcoHell
Apr 10, 2013
4,759
514
113
Bakersfield , CA
The door ajar switch in the lock actuators could be going bad. Could be the door harnesses. Could also be the bcm going bad.


Sent from the 4.hate using tapaturd
 

SamCarroll

Faux Runner
Staff member
Jan 25, 2011
7,740
1,979
113
Northern California
The door ajar switch in the lock actuators could be going bad. Could be the door harnesses. Could also be the bcm going bad.


Sent from the 4.hate using tapaturd

i guess ill try to clean and lube the latch assembly then move on to replacing it.

- - - - - - - - - -auto merged double post- - - - - - - - - -


lubing did nothing

hmmmmmm

I know this sounds stupid, but have you tried unplugging the battery fo ten mins then hooking back up?

yeah tried that yesterday when we re wired the radio
 
Last edited by a moderator:

ScottyBoy

The LED Man
Apr 6, 2012
1,320
21
38
I had this SAME exact problem a few years ago with my drivers door. The radio would stay on unless I opened one of the other doors, dome light wouldn't turn on with drivers door, etc.
I tried cleaning it which seemed to barely do anything. It worked like two or three times, but then started acting up again. I ended up replacing the power lock actuator/door latch assembly and all been been fine ever since. Why they integrated the power lock, latch, and the door pin switch all into one unit is beyond me. If one of the three acts up you have to replace the whole assembly.
 

SamCarroll

Faux Runner
Staff member
Jan 25, 2011
7,740
1,979
113
Northern California
Factory Alarm, figured out what the issue was last night.


Would this be the latch or the actuator?
 
Last edited by a moderator:

SamCarroll

Faux Runner
Staff member
Jan 25, 2011
7,740
1,979
113
Northern California
Installed the new actuators today. So far no issues. Install took about 30 min each side. Very easy and self explanatory. I'll report after some time if the problem has been rectified or not.

did you get the 30 dollar sensors? or have to spend the 200?

passenger side $30. Driver side had a third plug im guessing for power locks? Not really sure but they didnt make one with that option so you had to buy the whole unit for the driver side. So $212 for driver side.

This is the one he bought to replace the driver side.

https://www.amazon.com/APDTY-Integr...&keywords=06+sierra+driver+door+lock+actuator

See how it has the third plug and the band around the back? Different than the one Amazon said would work initially.
 
Last edited by a moderator: