Emery19

That Ford Guy
Apr 8, 2012
1,597
203
63
Mount Laurel, NJ
That's right, after countless years on GM forums with Fords I finally bought a GM. Don't worry though, my Powerstroke is still around.

Anyways, as some of you know, since the fall of 2013 I had been daily driving a 2005 Subaru. Well this past July with less then 100 miles short of 200k, the head gaskets blew and oil consumption finally caught up with it and I spun a bearing. Not having the time or want to put a motor in a car that old with that many miles, that wasn't a WRX or STI, I ended up just selling it. While this was all going on I was daily driving my truck and running the risk of getting fined by my condo association and their stupid rules. To add insult to injury, somebody decided they wanted the tailgate off my truck more then I did so I've been bombing around with either no tailgate or the white tailgate off my buddy's truck for the last two months.

The search had started for a 2011-2014 WRX to replace my 05 and I found a couple, but after thinking long and hard about it, I decided I didn't want a big loan right now because I'm looking at campers for next year and building the motor in my truck, so I didn't want to tie up money elsewhere on a car. I also decided that since I have no garage and my truck is already suffering from being outside all the time and the cautiousness of NJ drivers, I decided to hold off on getting a nice car I know I'll always be worried about.

Fast forward a couple of weeks and I drove 1997 Mustang that needed to much work, looked at a 2002 WRX held together with zip ties and looked at countless other things that didn't fit the bill, I was getting fed up at not knowing what I wanted for a new daily. Tossed around the idea of getting a cheap lease to drive for 3 years till I really figured out what I wanted and where my life was taking me, but the Honda Accord and Acura ILX I looked at were uninspiring and the Fiesta ST was too small and the Focus ST would be cheaper to buy and then I was back where I was with the WRX.

While all of this was going on, I was actually daily driving my buddies 6.0 Powerstroke, because the up-pipe on my truck blew out so it was basically undriveable because it wont build boost and my truck was also backed into his truck and now needs a bumper. so at this point after two months, I was down to 0 driveable vehicles and my vehicle luck was so horrible the jokes were even if I got a bicycle, it would break on me.


ANYWAYS, while cruising some lots near my friends house I stumbled upon what I ended up buying for a new daily. I realized I wasn't going to be happy in a car that wasn't fun, and after being in a truck for a month, I missed daily driving something that wasn't so small.

2001 Chevrolet Tahoe LS
1 owner
garaged its whole life
no accidents, clean carfax
145k miles
Pewter on Tan leather interior

Truck was factory ordered and to me has some weird options, but here are some highlights.

5.3
Leather Interior
Onstar (would love to ditch the buttons for a cubby like 03+)
no third row seats
dual zone climate control front and rear (not sure if that was standard on these things or not, I would think so)
Full console
Tow package
lift gate as opposed to the barn doors (not sure which year they switched)
etc etc.


Few things need addressed, one of the DRL's is amber, the other is clear, power mirrors only work in some directions, there's a squeak from what I assume is the AC belt, seems to be a fuel prime issue as it doesn't always start the first time, if I cycle the key it fires right up. and I think that's it. everything works as it supposed to and there is not one spec of rust anywhere for spending its whole life in PA. a couple imperfections in the paint, but for a 15 year old vehicle its damn clean. I really love it and I've always wanted one of these things so I finally got one.


It's SUPER old man status right now, but I'm working on that hopefully tomorrow. I've only had it for a week and I've been working a lot.

Plans are as follows:

Fix the issues as mentioned above

Remove
Bug deflector
Moldings
Pinstripe
mudflaps
possibly running boards
undecided on window guards
Onstar antenna on back window
lights under mirrors
I think all the badges are gone, unless I find anymore those will go
tape deck for a cubby

Add
Window Tint - unsure what % I don't want to go as dark as my truck which is 5% all around. At the very least, match the fronts and a 5% brow
swap my radio that was in my car over, its just a basic receiver with AUX
new speakers
DL3s with color matched caps
level or a 4"
NNBS Tahoe or GMC 20's
33" Duratracs
Airaid intake tube
BB tune or equivalent
a throatier muffler and dump the exhaust
weathertechs
black or z71 valance
clear heads
new dark border tails
03 console

Paint
Bumper cap
all 5 handles
bowtie
mirror caps

Any other suggestions on what I'm missing? Basically going to do the cheap stuff first make it look better while I gather parts for my truck build and work on finding a camper. This is my new daily and I'm extremely happy with it as is.


Photos ( i messed these up) more in next post
PQG5DYI.jpg
 
Last edited:

Emery19

That Ford Guy
Apr 8, 2012
1,597
203
63
Mount Laurel, NJ
r5zTxxu.jpg


RWhaQPq.jpg


kaSULFT.jpg


6WLCcRM.jpg


kaSULFT.jpg


OFVNarx.jpg




and both of my rigs together. limping my truck to my buddies in-laws so he can work on it. don't mind the light bar on his 6.0. His truck isn't a looker and he uses his bar when he's on the farm, he isn't a light bar brodozer. however he has gotten two tickets for it being uncovered.

bk5eFxS.jpg
 
Last edited:

slicksierra

Feel some type of way
Mar 8, 2012
5,462
174
63
29
Central Jersey
Looks great as far as the tint goes I would still put something on the back. It will be more expensive but stock dyed glass doesn't have the heat rejection I good film will have


live from the gutter trash.
 

slicksierra

Feel some type of way
Mar 8, 2012
5,462
174
63
29
Central Jersey
imo. just not sure how dark I want to go. don't want to have to do the dance I do in my truck trying to see backing up.

If you go back to dynamic just get the crystalline 40 or 50 over your stock glass in the rear. It's top of the line but it also rejects a lot of heat. But fully tinting a hoe with good tint will def be a few hundred bucks


live from the gutter trash.
 

Emery19

That Ford Guy
Apr 8, 2012
1,597
203
63
Mount Laurel, NJ
currently chasing a squeak that wont go away. new idler pully and tensioner and it still squeaks like a bitch. pulled the ac belt off and seems to have done away with the idle squeak, but still here some squeaks. new ac tensioner and main belt sitting on the passenger seat, ran out of daylight today. hopefully get it back together tomorrow.
 

ScottyBoy

The LED Man
Apr 6, 2012
1,320
21
38
As far as your other problems, those are pretty common minor problems on the GMT800 trucks and SUVs. You starting problem is a 90% chance that its the fuel pressure regulator, which is located on the drivers side fuel rail on the engine. But before you go buy a new one, closely inspect the small vacuum line that's connected to it. If that vacuum line is cracked or split, that can also cause it to have the symptoms that you are having.
And the poser mirror switches on the 99-02 trucks are notorious for acting up. Try taking the switch apart to clean the contacts. I've done that to a few and most of the time the switch started working.
Use a small pocket screwdriver to pop the switch open, but as you do so make sure that the button side is facing DOWN and the plug side is facing up. There is a small piece in there for the mirror select button that will fall out if the button side is not facing down on your table or workbench. Now once you get the switch back with circuit board separated off, slowly peel off the blue silicon rubber cover. This would also be a good time to scrub the blue cover with some alcohol and a small brush or q-tip if its filthy (95% of the time it will be covered in dirt). Now while you have that blue cover off waiting to dry, clean the metal contacts on the circuit board with a pencil eraser. Just use a pencil and scrub each contact with the eraser till it looks like bright copper. You will see black crud build up on the eraser while doing this. You can also try to carefully clean the small metal contacts on the blue silicone overlay as well.
Once its all cleaned up, pop it back together being careful about lining up that small white piece on the mirror select button that I mentioned earlier. Now get it together an pop it back in the truck to try it out. Now if it STILL doesn't work, then its time to order a new switch, or else try and determine if you have a problem with your actual mirror and not the switch.
 

Emery19

That Ford Guy
Apr 8, 2012
1,597
203
63
Mount Laurel, NJ
Damn really? they all show up for me. you on tapa or web?


Got the squeak to go away! Ac tensioner and a new serpentine belt and its all fixed. Now to take Scott's suggestions when I have time and mess with the other stuff.

Still have some de grandpa mode stuff to do to it, but I did take off the hood deflector so far. looks better. and I got my plates, fgt Jersey and its 2 plate rules. the front screws were security screws which I didn't have a bit for, but quick trip over to Mike's :shake: and I was able to put plates on.

ZRCad6M.jpg
 
Last edited:

Cleanoh4

Well-Known Member
Aug 27, 2013
4,340
182
63
37
NJ
Deem that's two shout outs in two days! Gotta do something with your add on lights on the mirrors though.
My dad was super jelly of your find too
 
Last edited:

Emery19

That Ford Guy
Apr 8, 2012
1,597
203
63
Mount Laurel, NJ
Old man tan ftw

:imo: when done right looks :boobs:

Deem that's two shout outs in two days! Gotta do something with your add on lights on the mirrors though.
My dad was super jelly of your find too

I know right? but there's holes in the bottom of the mirrors for the wires, so I'm trying to figure out the best way to remedy that. I haven't even traced the wires. Was he really? He was definitely into it. And he is exactly how I pictured he would be. Literally you, but older.

I can't see dem pics either. Not a single one in this thread.... :shrug:

Pics no work in webview

When I right click and open in new tab it asks me to sign into google.

No worky here either

I hope they're fixed now. I was just using image tags back to google photos, probably my problem. They're all on Imgur now so should work.