Important!: 1985 Gmc engine issue

dmaxboss22

New Member
Aug 2, 2016
6
0
1
22
I got a 1985 gmc k15. It has a 283 block in it. The truck sat for 10 years. It wouldn't fire so we replaced the distributer and it fired up and we timed it. It reved nicely in park but when put in gear and you stumped on it It wanted to shut off.. So I got another used carb off a 350 and advanced the timing a little and when i went to drive it I put pedal to the metal and it shifted with lower rpms. The rpms wouldn't increase because it seemed like it was shifting to early. Also when I was going up a hill it wouldn't climb pass 35mph. The engine wasn't getting high on rpms and wouldn't shift down. Plz help

Sent from my LG-D850 using Tapatalk
 

Khaos

Bed Dent Club Founder
Mar 24, 2012
20,376
1,563
113
29
Albany, NY
Did you do any other maintenance on the truck seeing as it has sat for 10 years?

Fluids, lines, cables, spark plugs, etc? Sitting that long, I would suspect that a lot of things have deteriorated. Could be part of the problem.
 

dmaxboss22

New Member
Aug 2, 2016
6
0
1
22
I haven't done anything but change the distributer and changed carburetor for a used carb that my friend said was good.

Sent from my LG-D850 using Tapatalk
 

dmaxboss22

New Member
Aug 2, 2016
6
0
1
22
Did you do any other maintenance on the truck seeing as it has sat for 10 years?

Fluids, lines, cables, spark plugs, etc? Sitting that long, I would suspect that a lot of things have deteriorated. Could be part of the problem.
I haven't done anything but change the distributer and changed carburetor for a used carb that my friend said was good.

Sent from my LG-D850 using Tapatalk
 

Oktain

Canuck Admin
Staff member
Feb 9, 2012
4,934
203
63
31
Sudbury, ON
Change all of your fluids and see if that helps. Even Roadkill replaces the ATF from time to time lol.