Electric Fans Run Constant

Discussion in 'Engine & Drivetrain Tech and Issues.' started by Bagged_Sierra, Jun 13, 2017.

  1. Bagged_Sierra

    Bagged_Sierra Member

    Messages:
    227
    Ok, my 13 Sierra has started this over the weekend. As soon as the engine starts the electric fans come on and run the entire time that the truck is running, even in the morning when its only around 60 degrees. I am thinking that it might be a relay or something like that but just wanted to see if any of you guys have had this problem to. Not sure if it is related but the AC light just flashes also and the AC compressor will not kick in, not sure if this is related or not.
     
  2. Ginger

    Ginger Bubbles

    Messages:
    23,877
    it is most likely related to that, as the fans are on when the AC is on, to pull air through the condenser.
     
    ScottyBoy likes this.
  3. ScottyBoy

    ScottyBoy The LED Man

    Messages:
    1,310
    I concur with Ginger.
     
  4. laidbackbigun

    laidbackbigun Member

    Messages:
    42
    Could be the relay, but also could be a short to ground depending on if the relay is a hot relay or a ground relay.
     
  5. Ginger

    Ginger Bubbles

    Messages:
    23,877
    hook up to a computer, preferable someone with tech2 and see what the AC issue is, and that will solve the e-fan issue.
     
  6. dszx13

    dszx13 Well-Known Member

    Messages:
    4,564
    This may help
    [​IMG]

    Sent from my SM-J100VPP using Tapatalk
     
    Last edited: Jun 15, 2017
  7. Bagged_Sierra

    Bagged_Sierra Member

    Messages:
    227
    Cool thanks guys, I am going to pull the relays later today and see if the relays are the problem, and if that doesn't fix it I will find someone with a Tech2 to see what it says.
     

Share This Page