2004 8.1L Ticking/Rattling @ 1800 RPM

Discussion in 'Maintenance' started by recycleoldgrowth, Aug 23, 2017.

  1. recycleoldgrowth

    recycleoldgrowth New Member

    Messages:
    13
    So my 8.1 has 130K, no mods. I'm the third owner, was sold to me out of Canada. Some good amount of rust on the undercarriage but nothing to alarming.

    Recently I hear a loud Ticking/Rattle right at 1800RPM that will continue if I hold it there. I'm assuming it's on of two things, lose heat shield or exhaust leak. I'm also getting a noticeable ticking sound when I accelerate and let off.

    I have also lost 2mpg. Rough idle as well. No codes. I'm going to put it up in the air this weekend to have a look but I'm here to ask for guidance as well. Thanks in advance.

    Sent from my SM-G530T using Tapatalk
     
  2. barrrf

    barrrf Active Member

    Messages:
    622
    manifold leak?
     
    recycleoldgrowth likes this.
  3. Khaos

    Khaos Bed Dent Club Founder

    Messages:
    20,554
    This. I'd check there first.
     
    recycleoldgrowth likes this.
  4. recycleoldgrowth

    recycleoldgrowth New Member

    Messages:
    13
    Would this also cause the negative Fuel Trim numbers I'm seeing? Wouldn't it be a positive number because the computer thinking it's got a lean condition? Thanks for your feedback.

    Sent from my SM-G530T using Tapatalk
     
  5. Ginger

    Ginger Bubbles

    Messages:
    23,971
    yes, because it is letting air in before the O2 sensors causing false readings.
     
  6. recycleoldgrowth

    recycleoldgrowth New Member

    Messages:
    13
    So yes it should show a positive number with unmetered air getting in before the O2 sensor?

    Sent from my SM-G530T using Tapatalk
     

Share This Page